Configurando vlans Packet Tracer

Tema en 'Redes Informáticas' iniciado por iPad, 13 Jun 2010.

  1. iPad

    iPad New Member

    Configurando vlans Packet Tracer

    ¿que es una vlan?
    una vlan es una virtual local area network, osea una red de area local virtual, usada para crear redes virtuales dentro de redes.

    ahora a la practica

    la idea es que la estructura qyuede como esta


    ahora lo haremos con las vlans 20, 30, 40, 50, 60 y 70
    primero armar el plano sin el cableado
    en esta ocacion como usaremos cableado serial debemos poner las interfaces y se apara el router y se colocan las tarjetas en las ranutas (todo en circulo rojo)


    usaremos 3 routers 8 switchs 4 pcs y 2 servidores dns


    luego le daremos el cableado, teniendo cuidade de cuando ponemos un sw con otro sw no conectarlo en la misma interfaz.

    en pc0 haremos vlan 20, en pc1 haremos vlan30, en pc2 haremos vlan 40, en pc3 haremos vlan 50, en server0 haremos vlan 60, y en server1 haremos vlan70:
    entre los routers haremos la tipica coneccion serial que seria:
    10.10.10.x/30
    por ende la 1º red sera 10.10.10.0 255.255.255.252 y comprende desde 10.10.10.0 hasta 10.10.10.3
    y la 2º red sera 10.10.10.4 255.255.255.252 y comprende desde 10.10.10.4 hasta 10.10.10.7
    las vlans las ahremos a partir de 192.168.16.x /27 por ende:

    PUERTAS DE ENLACE PARA LAS VLANS:
    en vlan20 192.168.16.33
    en vlan30 192.168.16.65
    en vlan40 192.168.16.97
    en vlan50 192.168.16.129
    en vlan60 192.168.16.161
    en vlan70 192.168.16.193


    ahora viene lo bonito
    en router0 que esta a la izkierda y esta mas cercxa de las vlan 20, 30, 40 y 50 se debe hacer lo sgte:

    enrar por CLI a la configuracion manual

    dijo:
    --- System Configuration Dialog ---

    Continue with configuration dialog? [yes/no]: no


    Press RETURN to get started!



    Router>enable
    Router#configure termina
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#interface f0/0
    Router(config-if)#no shut

    Router(config-if)#
    %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    exit
    Router(config)#interface f0/0.1

    %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
    Router(config-subif)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up

    Router(config-subif)#encapsulation dot1Q 20
    Router(config-subif)#ip address 192.168.16.33 255.255.255.224
    Router(config-subif)#exit
    Router(config)#

    y estaremos accediendo a la vlan20.
    NOTA: LOS COMANDOS INGRESADOS SON LO QUE DICE Router#,router(config)#, etc. lo que tiene un % ignorenlo pues es mensagfe de sistema.

    luego configurar la vlan 30:
    dijo:
    Router(config)#int f0/0.2
    Router(config-subif)#encapsulation dot1Q 30
    Router(config-subif)#ip address 192.168.16.65 255.255.255.224
    Router(config-subif)#no shut
    Router(config-subif)#exit
    Router(config)#


    configurando vlan40:
    dijo:
    Router(config)#int f0/0.3
    Router(config-subif)#encapsulation dot1Q 40
    Router(config-subif)#ip address 192.168.16.97 255.255.255.224
    Router(config-subif)#no shut
    Router(config-subif)#exit


    configurando vlan50
    dijo:
    Router(config)#int f0/0.4
    Router(config-subif)#encapsulation dot1Q 50
    Router(config-subif)#ip address 192.168.16.129 255.255.255.224
    Router(config-subif)#no shut
    Router(config-subif)#exit


    ahora le asignaremos ips a los pcs segun correspondan a cada segmento mencionado ya con anterioridad
    en vlan20 192.168.16.33 >>>>>.34 para pc
    en vlan30 192.168.16.65 >>>>>>66 para pc
    en vlan40 192.168.16.97>>>>>>.98 para pc
    en vlan50 192.168.16.129>>>>>.130 para pc

    luego se debe proceder a configurar los switch de la misma manera que los routers pero con los sgtes comandos:
    dijo:

    enable
    vlan database
    vlan xx name xxx
    vlan xx name xxx (la cantidad de vlans que hayan se hace lo mismo)
    exit

    en este caso se hace lo mismo en todos los sw y se pone:
    dijo:
    Switch>enable
    Switch#vlan database
    % Warning: It is recommended to configure VLAN from config mode,
    as VLAN database mode is being deprecated. Please consult user
    documentation for configuring VTP/VLAN in config mode.

    Switch(vlan)#vlan 20 name 20
    VLAN 20 added:
    Name: 20
    Switch(vlan)#vlan 30 name 30
    VLAN 30 added:
    Name: 30
    Switch(vlan)#vlan 40 name 40
    VLAN 40 added:
    Name: 40
    Switch(vlan)#vlan 50 name 50
    VLAN 50 added:
    Name: 50


    se hace e todos los switchs.

    luego de haberlo hecho todo como corresponde, se debe procedes a utilizar mode acces o mode trunk.
    los comandos son los siguientes:
    dijo:

    configure terminal
    int f0/1 (la que une el sw con el router, o el sw con otro sw)
    switchport mode trunk
    exit

    configure terminal
    int f0/2 (la que une el sw con los pcs)
    switchport mode access
    switchport access vlan 20 (la que este conectada)


    lo que quedaria asi:
    dijo:

    Switch#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Switch(config)#interface FastEthernet0/6
    Switch(config-if)#
    Switch(config-if)#
    Switch(config-if)#switchport access vlan 30
    Switch(config-if)#
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/1
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

    Switch(config-if)#switchport mode trunk
    Switch(config-if)#
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/2
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

    Switch(config-if)#switchport mode trunk
    Switch(config-if)#
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/3
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

    Switch(config-if)#switchport mode trunk
    Switch(config-if)#
    Switch(config-if)#exit
    Switch(config)#interface FastEthernet0/4
    Switch(config-if)#
    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down

    %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up

    Switch(config-if)#switchport mode trunk




    o bien tienen la manera grafica que es asi:



    RECUERDEN QUE SE DEBE HACER EN TODOS LOS SWITCHS.


    Y para terminar la coneccion de todo el lado de vlan 20 a 50 se debe hacer en el router:
    dijo:
    Router>enable
    Router#vlan database
    % Warning: It is recommended to configure VLAN from config mode,
    as VLAN database mode is being deprecated. Please consult user
    documentation for configuring VTP/VLAN in config mode.

    Router(vlan)#vlan 20 name 20
    VLAN 20 modified:
    Name: 20
    Router(vlan)#vlan 30 name 30
    VLAN 30 modified:
    Name: 30
    Router(vlan)#vlan 40 name 40
    VLAN 40 modified:
    Name: 40
    Router(vlan)#vlan 50 name 50
    VLAN 50 modified:
    Name: 50
    Router(vlan)#


    habiendo hecho todo paso a paso deberia haber completa conectividad dentre los 4 pcs y el router0.

    CONFIGURANDO LOS ROUERS:
    DEBEREMOS USAR PROTOCOLO DE ENRUTAMIENTO.
    yo recomiendo ospf y se hace asi:

    primero poner las ips de los segmentos mencionados al principio
    dijo:
    Router(config)#interface Serial0/0/0
    Router(config-if)#ip address 10.10.10.1 255.0.0.0
    Router(config-if)#ip address 10.10.10.1 255.255.255.252
    Router(config-if)#no shutdown
    Router(config-if)#clock rate 64000
    Router(config-if)#
    %LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

    %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up



    las ips usadas pueden variar segun sea dicho antes por el profesor, la empresa o uds mismos.

    ahora haremos uso de la lupa:

    http://i47.tinypic.com/3rosj.jpg

    que significa los circulos:
    la lupa. el router donde se usa y las redes que hay que conectar.
    el unico detalle es que aca no se usa la mascara, sino que se usa la wildcard y se calcula asi:

    si la mask es 255.255.255.224:
    255.255.255.255
    - 255.255.255.224
    0. 0. 0. 31

    por ende en router0 es:
    dijo:
    Router#
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#router ospf 1
    Router(config-router)#network 10.10.10.0 0.0.0.3 area 1
    Router(config-router)#network 192.168.16.128 0.0.0.31 area 1
    Router(config-router)#network 192.168.16.32 0.0.0.31 area 1
    Router(config-router)#network 192.168.16.64 0.0.0.31 area 1
    Router(config-router)#network 192.168.16.96 0.0.0.31 area 1
    Router(config-router)#end

    %SYS-5-CONFIG_I: Configured from console by console
    Router#wr
    Building configuration...
    [OK]


    en el otro router es mas facil pues solo hay 2 redes directamente conectadas
    http://i46.tinypic.com/4jl0lw.jpg

    dijo:

    Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#router ospf 1
    Router(config-router)#network 10.10.10.0 0.0.0.3 area 1
    Router(config-router)#network 10.10.10.4 0.0.0.3 area 1
    Router(config-router)#end
    Router#
    %SYS-5-CONFIG_I: Configured from console by console
    wr
    Building configuration...
    [OK]
    Router#


    ahora antes de empezar con router 2 haremos las vlans igual como hicimos en 1º instancia en el segmento anterior:
    dijo:

    Router>enable
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#interface FastEthernet0/0
    Router(config-if)#no shut
    Router(config-if)#exit
    Router(config)#int f0/0.1

    %LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
    Router(config-subif)#encapsulation dot1Q 60
    Router(config-subif)#ip add 192.168.16.161 255.255.255.224
    Router(config-subif)#exit
    Router(config)#int f0/0.2

    %LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
    Router(config-subif)#encapsulation dot1Q 70
    Router(config-subif)#ip address 192.168.16.193 255.255.255.224
    Router(config-subif)#end
    Router#
    %SYS-5-CONFIG_I: Configured from console by console
    wr
    Building configuration...
    [OK]


    y en los switch se hace lo mismo (mode access y mode trunk)
    dijo:

    enable
    vlan database
    vlan xx name xxx
    vlan xx name xxx (la cantidad de vlans que hayan se hace lo mismo)
    exit


    configure terminal
    int f0/1 (la que une el sw con el router)
    switchport mode trunk
    exit

    configure terminal
    int f0/2 (la que une el sw con los pcs)
    switchport mode access
    switchport access vlan 20 (la que este conectada)



    se asigna ip a los servidores y deberia haber completa comunicacion entre servers y router
    ahora la configuracion que falta en router 2 seria:
    dijo:

    Router#
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#router ospf 1
    Router(config-router)#net 10.10.10.4 0.0.0.3 area 1
    Router(config-router)#net 192.168.16.160 0.0.0.31 area 1
    Router(config-router)#net 192.168.16.192 0.0.0.31 area 1
    Router(config-router)#end

    %SYS-5-CONFIG_I: Configured from console by console
    Router#wr
    Building configuration...
    [OK]


    y deberia funcionar ping de extremo a extremo

    todo el credito al idolo kamo que me salvo
     

Compartir esta página