Tarjeta de red en DEBIAN

Tema en 'GNU / Linux' iniciado por P. Goñi, 7 Feb 2006.

Estado del tema:
Cerrado para nuevas respuestas
  1. P. Goñi

    P. Goñi Guest

    Hola,

    acabo de instalar Debian Sarge y durante el proceso me dijo que no detectaba
    la tarjeta de red y supuse que podía instalarla cuando arranque el
    escritorio.
    Ya tengo funcionando el sistema pero no tengo conexión de red y no encuentro
    dónde le puedo cofigurarla en el sistema.

    La tarjeta de red la tengo integrada en la placa base GIGABYTE 8i945 con
    pentium D.
    Si miro en windows el fabricante en INTEL y el modelo PRO/100. Le puse este
    modelo en el arranque pero no la detectó y seguí el proceso pero ahora no sé
    cofigurarla.

    ¿Alguien me echa una mano?

    También me dijo durante la instalación que algún paquete no se pudo
    instalar. Supongo que también los podré instalar por internet ¿no? Cuando
    pueda conectar claro :)

    Gracias.

    Un saludo.
     
  2. noname

    noname Guest

    P. Goñi wrote:

    > Ya tengo funcionando el sistema pero no tengo conexión de red y no encuentro
    > dónde le puedo cofigurarla en el sistema.


    Dale un vistazo a "man interfaces"

    Saludos

    F. Serrano
     
  3. P. Goñi escribió:
    > Hola,
    >
    > La tarjeta de red la tengo integrada en la placa base GIGABYTE 8i945 con
    > pentium D.
    > Si miro en windows el fabricante en INTEL y el modelo PRO/100. Le puse este
    > modelo en el arranque pero no la detectó y seguí el proceso pero ahora no sé
    > cofigurarla.



    Mira el chip con lspci, pero por lo que cuentas, el módulo debe ser e100
    o e1000.

    Sobre qué son los módulos, cómo se cargan, etc, mira en
    http://foros.escomposlinux.org/?page_name=Preguntas&menuaction=phpbrain.uikb.view_article&art_id=16


    > ¿Alguien me echa una mano?
    >
    > También me dijo durante la instalación que algún paquete no se pudo
    > instalar. Supongo que también los podré instalar por internet ¿no? Cuando
    > pueda conectar claro :)



    Sí, aunque aparte de detectar la tarjeta de red, tendrás que configurar
    la red. Mira el fichero /etc/network/interfaces, y más detalles en "man
    interfaces".

    Después, como seguramente tendrás el /etc/apt/sources.list sin entradas
    al no tener tarjeta durante la instalación, te recomiendo que ejecutes
    apt-setup para añadir repositorios, y luego, quizás tasksel te
    simplifique las cosas.


    Saludos.
     
  4. -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    P. Goñi wrote:

    > Ya tengo funcionando el sistema pero no tengo conexión de red y no
    > encuentro dónde le puedo cofigurarla en el sistema.


    Para configurarla a mano:

    ifconfig eth0 10.0.0.123 netmask 255.255.255.0 up
    route add default gw 10.0.0.1

    Donde "eth0" es la interfaz de tu tarjeta (si tienes dos, la segunda será
    eth1, etc); 10.0.0.123 es la IP que quieres tener, 255.255.255.0 es tu
    máscara, y 10.0.0.1 es el gateway por el que sales.


    Para dejar esta configuración fija -> a editar /etc/network/interfaces .
    "man interfaces" ayuda a la tarea.

    - --
    - ----------------------------------
    Iván Sánchez Ortega -i-punto-sanchez--arroba-mirame-punto-net

    http://acm.asoc.fi.upm.es/~mr/ ; http://acm.asoc.fi.upm.es/~ivan/
    MSN:i_eat_s_p_a_m_for_breakfast@hotmail.com
    Jabber:ivansanchez@jabber.org ; ivansanchez@kdetalk.net
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)

    iD8DBQFD5+4y3jcQ2mg3Pc8RAhwCAKCFAHv4hY+3Epm/lUDhpI8KxSInBACfUQUa
    kzBdz9i6uLgDrEqoi0saenE=
    =7JVN
    -----END PGP SIGNATURE-----
     
  5. P. Goñi

    P. Goñi Guest

    Hola,

    > ifconfig eth0 10.0.0.123 netmask 255.255.255.0 up
    > route add default gw 10.0.0.1
    >
    > Donde "eth0" es la interfaz de tu tarjeta (si tienes dos, la segunda será
    > eth1, etc); 10.0.0.123 es la IP que quieres tener, 255.255.255.0 es tu
    > máscara, y 10.0.0.1 es el gateway por el que sales.


    he hecho esto y me dice que el dispositivo no exixte. La dirección del
    gateway creo que no la sé porque tengo una IP dinámica que me da ONO.

    He hecho lspci y me detecta los dispositivos pero me dice que que son
    desconocidos. Por ejemplo, me detecta una tarjeta ethernet de: "Intel Corp.:
    Unknown Device 12ad" el número del final no lo recuerdo bien pero es algo
    así.

    Hay varios dispositivos de Intel en la placa base y en todos me dice
    "Unknown Device" pero me dice que es de intel.

    Lo mismo pasa con la tarjeta gráfica NVIDIA, me reconoce la marca pero no el
    modelo.

    En KDE he ido a ver el estado del núcleo y me dice que no tengo cargado
    ningún núcleo.Soy muy novato en Linux y apenas sé algo del núcleo. Antes
    tuve Mandrake 9.1 en un P3 500MHz pero todo funcionó bien a la primera.
    Con Debian estoy teniendo más problemas. Como comenté en el primer correo me
    dio problemas con la instalación de los paquetes ¿no se me habrá quedado
    algo en el DVD?

    Un saludo.
     
  6. -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    P. Goñi wrote:

    > Hola,
    >
    >> ifconfig eth0 10.0.0.123 netmask 255.255.255.0 up
    >> route add default gw 10.0.0.1

    >
    > he hecho esto y me dice que el dispositivo no exixte.


    Eso es que no tienes cargados los módulos del kernel necesarios. "modprobe
    e100".

    > La dirección del gateway creo que no la sé porque tengo una IP dinámica
    > que me da ONO.


    La dirección del gateway es la dirección *interna* del router. La externa
    (pública), no necesitas saberla, ni te importa (para lo que nos concierne,
    se supone).

    De cualquier manera, siempre puedes tirar de "dhclient eth0" para pillar una
    IP por DHCP.

    - --
    - ----------------------------------
    Iván Sánchez Ortega -i-punto-sanchez--arroba-mirame-punto-net

    Más vale mero aficionado que besugo profesional
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)

    iD8DBQFD6F/Z3jcQ2mg3Pc8RAr6zAJsHnGW+UB0V98+LQ4+aBJnwKyF2VgCfaPpU
    rOgeBXZc+85GDk0fQBBkWLs=
    =zXqt
    -----END PGP SIGNATURE-----
     
  7. Hola:

    P. Goñi escribió:

    > Hola,
    >
    > acabo de instalar Debian Sarge y durante el proceso me dijo que no
    > detectaba la tarjeta de red y supuse que podía instalarla cuando arranque
    > el escritorio.
    > Ya tengo funcionando el sistema pero no tengo conexión de red y no
    > encuentro dónde le puedo cofigurarla en el sistema.
    >
    > La tarjeta de red la tengo integrada en la placa base GIGABYTE 8i945 con
    > pentium D.
    > Si miro en windows el fabricante en INTEL y el modelo PRO/100.


    Como ya te han dicho, eso debería corresponderse con el módulo e100, el
    e100pro o el e1000.

    > Le puse
    > este modelo en el arranque pero no la detectó y seguí el proceso pero
    > ahora no sé cofigurarla.


    Hay modelos de Intel que no son reconocidos por el kernel (especialmente en
    la serie 2.4): para ellos, deberás descargarte el código fuente de la web
    de Intel y compilar el módulo correspondiente.
     
  8. P. Goñi

    P. Goñi Guest


    >
    > Hay modelos de Intel que no son reconocidos por el kernel (especialmente
    > en
    > la serie 2.4): para ellos, deberás descargarte el código fuente de la web
    > de Intel y compilar el módulo correspondiente.


    Si no es mucho pedir, ¿Cómo compilo ese módulo? Quiero decir ¿Qué comando
    utilizo?

    Gracias por la respuesta.
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página