ppp y gprs

Tema en 'GNU / Linux' iniciado por Eismann, 22 Mar 2006.

Estado del tema:
Cerrado para nuevas respuestas
  1. Eismann

    Eismann Guest

    Hola Estoy intentando conectarme a internet mediante un modem GPRS
    conectado al puerto serie y PPP. Parece que consigo realizar la
    conexión, pero no soy capaz de acceder a ningún sitio. Se me asigna
    una IP a ppp0, pero los pings se pierden y el traceroute no me muestra
    nada. He intentado conectarme con kppp y haciéndome mis scripts, pero
    el resultado es el mismo. Pego los scripts que he usado y los
    resultados que he obtenido: options-gprs (este lo he sacado de
    es.comp.os.linux.redes): ------ receive-all nopcomp noaccomp nomagic
    debug debug debug nodetach defaultroute noipdefault modem /dev/ttyS0 #
    57600 115200 -crtscts local #connect '/usr/sbin/chat -e -f
    /etc/ppp/chat-connect -v' #disconnect '/usr/sbin/chat -e -f
    /etc/ppp/chat-disconnect -v' #crtscts noauth noccp novj novjccomp
    #passive #asyncmap 0 user cliente name "cliente" lock ------
    ppp-on-dialer-gprs ----- #!/bin/sh /usr/sbin/chat -v
    \ ABORT 'BUSY'
    \ ABORT 'ERROR' \ ABORT 'NO ANSWER'
    \ ABORT 'NO CARRIER' \ ABORT 'NO
    DIALTONE' \ ABORT 'Invalid Login'
    \ ABORT 'Login incorrect' \ '' 'ATZ'
    \ 'TIMEOUT' '10' \ 'OK'
    'ATM1L1' \ 'OK'
    'AT&f+cgdcont=1,"IP","internet","",0,0' \ 'OK'
    'ATX3' \ 'OK' 'ATDT*99***1#'
    \ 'CONNECT' '' ------- Esto es lo que ejecuto como root: pppd
    file options-gprs connect ppp-on-dialer-gprs Y me sale lo siguiente:
    --------- Serial connection established. using channel 10 Using
    interface ppp0 Connect: ppp0 <--> /dev/ttyS0 sent [LCP ConfReq id=0x1
    <asyncmap 0x0>] rcvd [LCP ConfAck id=0x1 <asyncmap 0x0>] rcvd [LCP
    ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xe9c50500>] sent [LCP
    ConfRej id=0x1 <magic 0xe9c50500>] rcvd [LCP ConfReq id=0x2 <asyncmap
    0x0> <auth pap>] sent [LCP ConfAck id=0x2 <asyncmap 0x0> <auth pap>]
    sent [LCP EchoReq id=0x0 magic=0x0] sent [PAP AuthReq id=0x1
    user="cliente" password=<hidden>] rcvd [LCP EchoRep id=0x0 magic=0x0]
    rcvd [PAP AuthAck id=0x1 "Welcome!"] Remote message: Welcome! PAP
    authentication succeeded sent [IPCP ConfReq id=0x1 <addr 0.0.0.0>] rcvd
    [IPCP ConfReq id=0x2 <addr 213.143.62.67>] sent [IPCP ConfAck id=0x2
    <addr 213.143.62.67>] rcvd [IPCP ConfNak id=0x1 <addr 213.143.60.242>]
    sent [IPCP ConfReq id=0x2 <addr 213.143.60.242>] rcvd [IPCP ConfAck
    id=0x2 <addr 213.143.60.242>] not replacing default route to eth0
    [172.26.0.1] Cannot determine ethernet address for proxy ARP local IP
    address 213.143.60.242 remote IP address 213.143.62.67 Script
    /etc/ppp/ip-up started (pid 12905) Script /etc/ppp/ip-up finished (pid
    12905), status = 0x0 sent [LCP EchoReq id=0x1 magic=0x0] rcvd [LCP
    EchoRep id=0x1 magic=0x0] sent [LCP EchoReq id=0x2 magic=0x0] rcvd [LCP
    EchoRep id=0x2 magic=0x0] -------- Y cuando mato a pppd: --------
    Terminating on signal 15 Connect time 1.4 minutes. Sent 504 bytes,
    received 1412 bytes. Script /etc/ppp/ip-down started (pid 12961) sent
    [LCP TermReq id=0x2 "User request"] Script /etc/ppp/ip-down finished
    (pid 12961), status = 0x0 sent [LCP TermReq id=0x3 "User request"] rcvd
    [LCP TermReq id=0x3 "User request"] sent [LCP TermAck id=0x3] rcvd [LCP
    TermAck id=0x3] Connection terminated. --------- Salida de ifconfig
    para ppp0: --------- ppp0 Link encap:point-to-Point Protocol
    inet addr:213.143.60.242 P-t-P:213.143.62.67 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:3 errors:0 dropped:0 overruns:0 frame:0 TX
    packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3 RX bytes:30 (30.0 b) TX bytes:30
    (30.0 b) --------- Ping a google por ppp0 (por eth0 funciona):
    --------- aitor@kubuntu:~/ppp$ ping -I ppp0 www.google.es PING
    www.l.google.com (216.239.59.103) from 172.26.0.12 ppp0: 56(84) bytes
    of data. --- www.l.google.com ping statistics --- 6 packets
    transmitted, 0 received, 100% packet loss, time 4998ms --------- Lo
    que no sé es por qué me dice que "PAP authentication succeeded" si yo
    no le doy ningún password. Con el kppp si se lo doy. Estoy usando una
    kubuntu 5.10, kernel 2.6.12 y la tarjeta de teléfono es de amena.
    Saludos y gracias, Eismann
     
  2. Eismann

    Eismann Guest

    Hola

    Estoy intentando conectarme a internet mediante un modem GPRS conectado
    al puerto serie y PPP.

    Parece que consigo realizar la conexión, pero no soy capaz de acceder a
    ningn sitio.
    Se me asigna una IP a ppp0, pero los pings se pierden y el traceroute
    no me muestra nada.

    He intentado conectarme con kppp y haciéndome mis scripts, pero el
    resultado es el mismo. Pego los scripts que he usado y los resultados
    que he obtenido:

    options-gprs (este lo he sacado de es.comp.os.linux.redes):
    ------
    receive-all
    nopcomp
    noaccomp
    nomagic
    debug debug debug
    nodetach
    defaultroute
    noipdefault
    modem
    /dev/ttyS0
    # 57600
    115200
    -crtscts
    local
    #connect '/usr/sbin/chat -e -f /etc/ppp/chat-connect -v'
    #disconnect '/usr/sbin/chat -e -f /etc/ppp/chat-disconnect -v'
    #crtscts
    noauth
    noccp
    novj
    novjccomp
    #passive
    #asyncmap 0
    user cliente
    name "cliente"
    lock
    ------

    ppp-on-dialer-gprs
    -----
    #!/bin/sh
    /usr/sbin/chat -v \
    ABORT 'BUSY' \
    ABORT 'ERROR' \
    ABORT 'NO ANSWER' \
    ABORT 'NO CARRIER' \
    ABORT 'NO DIALTONE' \
    ABORT 'Invalid Login' \
    ABORT 'Login incorrect' \
    '' 'ATZ' \
    'TIMEOUT' '10' \
    'OK' 'ATM1L1' \
    'OK' 'AT&f+cgdcont=1,"IP","internet","",0,0' \
    'OK' 'ATX3' \
    'OK' 'ATDT*99***1#' \
    'CONNECT' ''
    -------

    Esto es lo que ejecuto como root:
    pppd file options-gprs connect ppp-on-dialer-gprs

    Y me sale lo siguiente:
    ---------
    Serial connection established.
    using channel 10
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyS0
    sent [LCP ConfReq id=0x1 <asyncmap 0x0>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0>]
    rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xe9c50500>]
    sent [LCP ConfRej id=0x1 <magic 0xe9c50500>]
    rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth pap>]
    sent [LCP ConfAck id=0x2 <asyncmap 0x0> <auth pap>]
    sent [LCP EchoReq id=0x0 magic=0x0]
    sent [PAP AuthReq id=0x1 user="cliente" password=<hidden>]
    rcvd [LCP EchoRep id=0x0 magic=0x0]
    rcvd [PAP AuthAck id=0x1 "Welcome!"]
    Remote message: Welcome!
    PAP authentication succeeded
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0>]
    rcvd [IPCP ConfReq id=0x2 <addr 213.143.62.67>]
    sent [IPCP ConfAck id=0x2 <addr 213.143.62.67>]
    rcvd [IPCP ConfNak id=0x1 <addr 213.143.60.242>]
    sent [IPCP ConfReq id=0x2 <addr 213.143.60.242>]
    rcvd [IPCP ConfAck id=0x2 <addr 213.143.60.242>]
    not replacing default route to eth0 [172.26.0.1]
    Cannot determine ethernet address for proxy ARP
    local IP address 213.143.60.242
    remote IP address 213.143.62.67
    Script /etc/ppp/ip-up started (pid 12905)
    Script /etc/ppp/ip-up finished (pid 12905), status = 0x0
    sent [LCP EchoReq id=0x1 magic=0x0]
    rcvd [LCP EchoRep id=0x1 magic=0x0]
    sent [LCP EchoReq id=0x2 magic=0x0]
    rcvd [LCP EchoRep id=0x2 magic=0x0]
    --------


    Y cuando mato a pppd:
    --------
    Terminating on signal 15
    Connect time 1.4 minutes.
    Sent 504 bytes, received 1412 bytes.
    Script /etc/ppp/ip-down started (pid 12961)
    sent [LCP TermReq id=0x2 "User request"]
    Script /etc/ppp/ip-down finished (pid 12961), status = 0x0
    sent [LCP TermReq id=0x3 "User request"]
    rcvd [LCP TermReq id=0x3 "User request"]
    sent [LCP TermAck id=0x3]
    rcvd [LCP TermAck id=0x3]
    Connection terminated.
    ---------

    Salida de ifconfig para ppp0:
    ---------
    ppp0 Link encap:point-to-Point Protocol
    inet addr:213.143.60.242 P-t-P:213.143.62.67
    Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:3 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:30 (30.0 b) TX bytes:30 (30.0 b)
    ---------


    Ping a google por ppp0 (por eth0 funciona):
    ---------
    aitor@kubuntu:~/ppp$ ping -I ppp0 www.google.es
    PING www.l.google.com (216.239.59.103) from 172.26.0.12 ppp0: 56(84)
    bytes of data.

    --- www.l.google.com ping statistics ---
    6 packets transmitted, 0 received, 100% packet loss, time 4998ms
    ---------


    Lo que no sé es por qué me dice que "PAP authentication succeeded" si
    yo no le doy ningún password. Con el kppp si se lo doy.

    Estoy usando una kubuntu 5.10, kernel 2.6.12 y la tarjeta de teléfono
    es de amena.


    Saludos y gracias,
    Eismann
     
  3. Eismann

    Eismann Guest

    Hola

    Estoy intentando conectarme a internet mediante un modem GPRS conectado
    al puerto serie y PPP.

    Parece que consigo realizar la conexión, pero no soy capaz de acceder a
    ningn sitio.
    Se me asigna una IP a ppp0, pero los pings se pierden y el traceroute
    no me muestra nada.

    He intentado conectarme con kppp y haciéndome mis scripts, pero el
    resultado es el mismo. Pego los scripts que he usado y los resultados
    que he obtenido:

    options-gprs (este lo he sacado de es.comp.os.linux.redes):
    ------
    receive-all
    nopcomp
    noaccomp
    nomagic
    debug debug debug
    nodetach
    defaultroute
    noipdefault
    modem
    /dev/ttyS0
    # 57600
    115200
    -crtscts
    local
    #connect '/usr/sbin/chat -e -f /etc/ppp/chat-connect -v'
    #disconnect '/usr/sbin/chat -e -f /etc/ppp/chat-disconnect -v'
    #crtscts
    noauth
    noccp
    novj
    novjccomp
    #passive
    #asyncmap 0
    user cliente
    name "cliente"
    lock
    ------

    ppp-on-dialer-gprs
    -----
    #!/bin/sh
    /usr/sbin/chat -v \
    ABORT 'BUSY' \
    ABORT 'ERROR' \
    ABORT 'NO ANSWER' \
    ABORT 'NO CARRIER' \
    ABORT 'NO DIALTONE' \
    ABORT 'Invalid Login' \
    ABORT 'Login incorrect' \
    '' 'ATZ' \
    'TIMEOUT' '10' \
    'OK' 'ATM1L1' \
    'OK' 'AT&f+cgdcont=1,"IP","internet","",0,0' \
    'OK' 'ATX3' \
    'OK' 'ATDT*99***1#' \
    'CONNECT' ''
    -------

    Esto es lo que ejecuto como root:
    pppd file options-gprs connect ppp-on-dialer-gprs

    Y me sale lo siguiente:
    ---------
    Serial connection established.
    using channel 10
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyS0
    sent [LCP ConfReq id=0x1 <asyncmap 0x0>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0>]
    rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xe9c50500>]
    sent [LCP ConfRej id=0x1 <magic 0xe9c50500>]
    rcvd [LCP ConfReq id=0x2 <asyncmap 0x0> <auth pap>]
    sent [LCP ConfAck id=0x2 <asyncmap 0x0> <auth pap>]
    sent [LCP EchoReq id=0x0 magic=0x0]
    sent [PAP AuthReq id=0x1 user="cliente" password=<hidden>]
    rcvd [LCP EchoRep id=0x0 magic=0x0]
    rcvd [PAP AuthAck id=0x1 "Welcome!"]
    Remote message: Welcome!
    PAP authentication succeeded
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0>]
    rcvd [IPCP ConfReq id=0x2 <addr 213.143.62.67>]
    sent [IPCP ConfAck id=0x2 <addr 213.143.62.67>]
    rcvd [IPCP ConfNak id=0x1 <addr 213.143.60.242>]
    sent [IPCP ConfReq id=0x2 <addr 213.143.60.242>]
    rcvd [IPCP ConfAck id=0x2 <addr 213.143.60.242>]
    not replacing default route to eth0 [172.26.0.1]
    Cannot determine ethernet address for proxy ARP
    local IP address 213.143.60.242
    remote IP address 213.143.62.67
    Script /etc/ppp/ip-up started (pid 12905)
    Script /etc/ppp/ip-up finished (pid 12905), status = 0x0
    sent [LCP EchoReq id=0x1 magic=0x0]
    rcvd [LCP EchoRep id=0x1 magic=0x0]
    sent [LCP EchoReq id=0x2 magic=0x0]
    rcvd [LCP EchoRep id=0x2 magic=0x0]
    --------


    Y cuando mato a pppd:
    --------
    Terminating on signal 15
    Connect time 1.4 minutes.
    Sent 504 bytes, received 1412 bytes.
    Script /etc/ppp/ip-down started (pid 12961)
    sent [LCP TermReq id=0x2 "User request"]
    Script /etc/ppp/ip-down finished (pid 12961), status = 0x0
    sent [LCP TermReq id=0x3 "User request"]
    rcvd [LCP TermReq id=0x3 "User request"]
    sent [LCP TermAck id=0x3]
    rcvd [LCP TermAck id=0x3]
    Connection terminated.
    ---------

    Salida de ifconfig para ppp0:
    ---------
    ppp0 Link encap:point-to-Point Protocol
    inet addr:213.143.60.242 P-t-P:213.143.62.67
    Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:3 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:30 (30.0 b) TX bytes:30 (30.0 b)
    ---------


    Ping a google por ppp0 (por eth0 funciona):
    ---------
    aitor@kubuntu:~/ppp$ ping -I ppp0 www.google.es
    PING www.l.google.com (216.239.59.103) from 172.26.0.12 ppp0: 56(84)
    bytes of data.

    --- www.l.google.com ping statistics ---
    6 packets transmitted, 0 received, 100% packet loss, time 4998ms
    ---------


    Lo que no sé es por qué me dice que "PAP authentication succeeded" si
    yo no le doy ningún password. Con el kppp si se lo doy.

    Estoy usando una kubuntu 5.10, kernel 2.6.12 y la tarjeta de teléfono
    es de amena.


    Saludos y gracias,
    Eismann
     
  4. Hola "Eismann" <g.eismann@gmail.com>
    el 22 Mar 2006 05:00:49 -0800 escribiste:

    > Esto es lo que ejecuto como root:
    > pppd file options-gprs connect ppp-on-dialer-gprs
    >
    > Y me sale lo siguiente:
    > [...]
    > not replacing default route to eth0 [172.26.0.1]


    PPP ve que ya tienes una ruta por defecto y la deja como
    está. Eso quiere decir que todo el tráfico *genérico*
    se irá a eth0

    Puedes ver la tabla de rutas con la orden "/sbin/route -n".

    > Lo que no s_ es por qu_ me dice que "PAP authentication succeeded" si
    > yo no le doy ning_n password. Con el kppp si se lo doy.


    El password está en /etc/ppp/pap-secrets. Supongo que lo que hace
    kppp es escribirlo ahí (pero realmente no tengo ni idea de lo que hace
    kppp).

    --
    Gonzalo Pérez de Olaguer Córdoba <gpoc@iies.es>
    PGP key 2861C704 --- F206 5671 6789 425D 111C 1302 214F 1934 2861 C704
     
  5. Eismann

    Eismann Guest

    Gonzalo ha escrito:

    > PPP ve que ya tienes una ruta por defecto y la deja como
    > está. Eso quiere decir que todo el tráfico *genérico*
    > se irá a eth0
    >
    > Puedes ver la tabla de rutas con la orden "/sbin/route -n".


    Vale, he cambiado la tabla de rutas y ya me funciona.

    Muchas gracias,
    Eismann.
     
Estado del tema:
Cerrado para nuevas respuestas

Compartir esta página